FC2ブログ
自分の備忘録ぐらいに適当に。 ネットワークと宇宙開発と天文とそれと自転車を徒然と。

備忘録。

CatalystスイッチでEtherChannelのロードバランスでどの物理インタフェースに出力されるかを確認する方法。

■ Catalyst2960X(IOS) ■
test etherchannel load-balance interface port-channel <CH_NUM> ip <送信元IP> <宛先IP>


■ Catalyst6500(IOS) ■
show etherchannel load-balance hash-result interface port-channel <CH_NUM> ip <送信元IP> <宛先IP>
※古いSupの場合は、上と同じかも。
 少なくともSwitch Processorは上のコマンドになります。


■ Catalyst3650/3850(IOS-XE) ■
show platform etherchannel <CH_NUM> load-balance ip <送信元IP> <宛先IP>

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3850/software/release/3se/layer2/command_reference/b_lay2_3se_3850_cr/b_lay2_3se_3850_cr_chapter_010.html


■ Catalyst4500X(IOS-XE) ■
show platform software etherchannel port-channel <CH_NUM> map ip <送信元IP> <宛先IP>

https://supportforums.cisco.com/document/69496/etherchannel-loadbalancing-catalyst-switches

スポンサーサイト




【2017/04/09 20:58】 | EtherChannel
トラックバック(0) |
備忘録。

Bondingのモードについてよくまとまっている情報がHPのページにあったので。

検索等でたどり着いてしまった人は元ページのこちらを見てください。。
HPE
製品  >  ソフトウェア  >  Linux
bondingドライバの違いについて
以下、HPEのページの画面キャプチャデータです。
HP_bonding.png

サーバの冗長化NICを上位の2つのスイッチに接続をする場合、
・Stack構成なら802.3ad
・STP構成(Stack構成ではない)ならactive-backup

になるかと。

ちなみに
・サーバ側がactive-backupモード
・スイッチ側が802.3ad

とサーバとスイッチでモードが違っていたりすると、スイッチ側→サーバ側への通信の際に、backup側に通信が流れることがあります。
というのもスイッチ側のMAC address tableには802.3adのLAGインタフェースにMAC addressが紐づき、個々の物理インタフェースには紐づきません。そのためLAGのロードバランスのアルゴリズムでメンバーの物理インタフェースにフレームが転送されます。

そうするとサーバ側としてはbackupとして設定・状態になっているはインタフェースにフレームが到達してしまうことがあり、backup側はそのフレームを破棄し、dropカウンターがカウントアップしますし、通信も上手くいく相手もあればうまくいかない相手があるという切り分けに苦労する状態になります。

そういう場合は、サーバ側で
ifconfig
を実施し、bondingのメンバーとなっているメンバーの物理インタフェースであるeth1,eth2,等々の
RXでdroppedのカウントアップが発生していないか
確認してみてください。

サーバ側で実際にどの物理インタフェースがactiveになっているかは
cat /proc/net/bonding/bond0
で確認できます。




【2017/04/09 20:45】 | EtherChannel
トラックバック(0) |
備忘録。

関連記事は こちら(EtherChannelの呼び方)

サーバ系のLink Aggregationなどの冗長化構成の説明など。

Intel
アドバンスド・ネットワーキング・サービス
チーミング機能
http://www.intel.com/jp/support/network/sb/cs-009747.htm

レッドハット オープンソース・カンパニー
RHEL5のbonding設定
http://www.jp.redhat.com/magazine/jp/200904/rhel.html

JFEテクノリサーチ株式会社 ITプロフェッショナル・サービス
8) NIC冗長化設定 (bonding設定)
http://it.jfe-tec.jp/column/tech_column/column_linuxn/000104.html

PCサーバ PRIMERGY(プライマジー) 技術情報 富士通
http://primeserver.fujitsu.com/primergy/technical/
[技術資料] LAN 冗長化をする際の注意事項
http://primeserver.fujitsu.com/primergy/pdf/note/teaming-note.pdf



【2011/10/29 13:10】 | EtherChannel
|
備忘録。

関連記事は こちら(ISR G1の搭載インタフェース(Routed)でのEtherChannel)

ちょっとIOSの体系が違いますが最近センター系などで使い始めている ASR1000 シリーズの IOS-XE ではEtherChannelができるだけでなく
VLAN単位
のロードバランスができるようになっています。

LAN Switching Configuration Guide,
Cisco IOS XE Release 3S

P.33
VLAN Mapping to Gigabit EtherChannel
Member Links

http://www.cisco.com/en/US/docs/ios-xml/ios/lanswitch/configuration/xe-3s/lanswitch-xe-3s-book.pdf
※どういう訳かPDFには記載があるのですがHTMLには記載がないです。
http://www.cisco.com/en/US/docs/ios-xml/ios/lanswitch/configuration/xe-3s/lanswitch-xe-3s-book.html

ただサンプルコンフィグを見てもちょっとIP addressの体系など見るとちょっとピンと来ないので実際試して見たいですね。
※VRFが分かれていない状態で同じアドレス帯を設定することって普通のルータだとできないと思うのですが。。。


【2011/10/23 22:19】 | EtherChannel
|
備忘録。

ISR G1(Cisco2801を除く、2800シリーズ(2811,2821,2851)、3800シリーズ(3825,3845))では 12.4(17.6) 以降で本体内蔵(Routed)の FastEthernetインタフェース、GigabitEthernetインタフェースで EtherChannel を構成することが可能です。
※Cisco2801は2800シリーズの中でIOSが違ってましたからね。

Understanding Layer3 EtherChannel Support on the Cisco Integrated Services Router
http://www.cisco.com/en/US/prod/collateral/routers/ps5855/prod_white_paper0900aecd806f698a.pdf

------------------------------------------------------
In Cisco IOS Release 12.4(17.6), EtherChannel support is introduced for embedded Fast Ethernet and Gigabit Ethernet interfaces on Cisco2811, Cisco2821, Cisco2851, Cisco3825 and Cisco3845.Additionally, the same feature is also supported on the NM-1GE, HWIC-1GE-SFP, HWIC-1FE and HWIC-2FE modules in the earlier IOS release.
------------------------------------------------------

また同じPDFファイル 6ページ の上段には どの本体内蔵/HWIC/NM で、どのIOSバージョンから EtherChannel に対応しているかということが表になって記載があります。


基本的な設定は以下の通りです。
-------------------------------------------
interface Port-channel1
 ip address 192.168.0.1 255.255.255.0
!
interface range GigabitEthernet0/0 - 1
 channel-group 1

!
-------------------------------------------
設定順番としてはCatalystスイッチとは違い、
1. 先に”interface Port-channel X”を設定
2. 物理インタフェースに”channel-group X”を設定
します。
ただEtherChannelの管理プロトコルである PAgP や LACP に対応はしていません (mode on状態)。

また、sub interface にも対応しています。
-------------------------------------------
interface Port-channel1
!
interface Port-channel1.1
 encapsulation dot1Q 10

 ip address 192.168.1.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 20

 ip address 192.168.2.1 255.255.255.0
!
interface range GigabitEthernet0/0 - 1
 channel-group 1

!
-------------------------------------------


なお、G2シリーズについてもちょっとCCO上の記載は見つけられないのですが、G2シリーズも本体内蔵インタフェース間での対応しているようです。



【2010/12/28 00:39】 | EtherChannel
|


とおりすがり
なるほど。

物理ポート同士もできるようになったんですね。
知りませんでした!


supersense
やっぱり VLAN を使うにはサブインターフェイスを立てる必要があるんですね。

interface port-channel1
switchport trunk allowed vlan 10
switchport mode trunk

interface range GigabitEthernet0/0 - 1
channel-group 1

interface vlan10
ip address 192.168.1.1 255.255.255.0

って書ければ嬉しいのですが。

コメントを閉じる▲
備忘録。

EtherChannel には Layer3Layer2 の EtherChannel があるわけですが、Layer2 にはさらに Access 設定と VLAN Trunk(Tagging) があります。

で、VLAN Trunk を設定している EtherChannel に VLAN を追加しようとしたとき、Port-Channel 自体に設定するのか Port-Channel のメンバーポート(物理インタフェース)に設定するのか?となりますが、Port-Channel 自体に設定します。これは Port-Channel 自体に設定した VLAN Trunk 設定は自動的にメンバーポートにその設定が反映されるためです。

これを間違って逆に Port-Channel を構成するメンバーポートに設定したときは Port-Channel 自体のVLAN Trunk設定とメンバーポートとのVLAN Trunk設定に相違が発生(vlan mask is different)していまい、物理インタフェースが
-----
 GigabitEthernet1/0/1 is up, line protocol is down (suspended)
-----
 となってしまいます。そしてそれに引きづられてPo1もDown, Downとなってしまいます。
-----
 Port-channel1 is down, line protocol is down (notconnect)
-----


○実際の設定例
==========================================================================================
L3SW#
L3SW#sh run int po1
Building configuration...

Current configuration : 197 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-325
switchport mode trunk
switchport nonegotiate
spanning-tree link-type point-to-point
end

L3SW#
L3SW#sh run int gi1/0/1
Building configuration...

Current configuration : 189 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-325
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

L3SW#
L3SW#sh run int gi1/0/2
Building configuration...

Current configuration : 189 bytes
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-325
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

L3SW#
L3SW#conf t
L3SW(config)#int po 1
L3SW(config-if)# switchport trunk allowed vlan add 326-330
L3SW(config-if)#end
L3SW#
L3SW#sh run int po 1
Building configuration...

Current configuration : 197 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-330
switchport mode trunk
switchport nonegotiate
spanning-tree link-type point-to-point
end

L3SW#
L3SW#sh run int gi1/0/1
Building configuration...

Current configuration : 189 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-330 ← 設定自体は Po1 だけだがメンバーポートにも反映される
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

L3SW#
L3SW#sh run int gi1/0/2
Building configuration...

Current configuration : 189 bytes
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,300-330 ← 設定自体は Po1 だけだがメンバーポートにも反映される
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
end

L3SW#
==========================================================================================


ちなみに VLAN Trunk に VLAN を追加する際には ”switchport trunk allowed vlan add ”コマンドを使用します、”add ”をつけ忘れると設定しようとしているVLANのみ置き換わってしまうのでかなり痛い目見ます。

となみに^2 spanning-tree 設定などはPort-Channel、メンバーポートそれぞれ個別に設定することになります。


【2010/11/23 20:00】 | EtherChannel
|


CENT
portchannel がうまく組めなく苦しんでました。
(vlan mask is different)とでてまったくわからず混乱していましたがおかげで助かりました。本当にありがとうございます

コメントを閉じる▲